【技术分享】MySQL 与Django版本匹配相关经验

Yuchuan 发表于 2020/08/01 20:09:20 2020/08/01
【摘要】 MySQL 与Django版本匹配相关知识

run:

(env) E:\PythonPro\PyDjangoProDemo011\xuanyuaniotpro>python manage.py migrate

报错代码提示如下:

raise errorclass(errno, errval)
django.db.utils.ProgrammingError: (1064, "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '(6) NOT NULL)' at line 1")
During handling of the above exception, another exception occurred:

image.png

根据提示分析报错原因:

Django2.1不再支持MySQL5.5,必须5.6版本以上

查mysql版本和Django版本:

mysql版本:

image.png

Django版本:

image.png

根据原因分析得出解决思路:

二选一

(1)Django降级到2.0

(env) PS E:\PythonPro\PyDjangoProDemo011\xuanyuaniotpro> pip install Django==2.0.0 -i https://pypi.douban.com/simple

image.png

>>> import django
>>> django.VERSION

image.png

(env) PS E:\PythonPro\PyDjangoProDemo011\xuanyuaniotpro> python .\manage.py makemigrations
No changes detected
(env) PS E:\PythonPro\PyDjangoProDemo011\xuanyuaniotpro>
(env) PS E:\PythonPro\PyDjangoProDemo011\xuanyuaniotpro> python .\manage.py migrate

image.png

image.png

成功连接数据库。

(2)MySQL升级

1.查看MySQL的版本

mysql --version
mysql  Version 14.14 Distrib 5.5.28, for Linux (x86_64) using reeadline 5.1
从上面可以看出,MySQL版本为5.5.28

2.查看MySQL的安装包

yum list | grep mysql
注意:如果没有看到想要升级的版本,请更新yum安装库,具体操作如下:
1) wget http://dev.mysql.com/get/mysql-community-release-el6-5.noarch.rpm
2) rpm -ivh mysql-community-release-el6-5.noarch.rpm
3) 重新查看即可,yum list | grep mysql

3.查看当前已经安装的MySQL安装相关信息

yum list | grep ^mysql
注意:这里的^代表以mysql开头的项
-----------
yum info mysql-server
据说,上面的命令执行完毕后可以看到可升级的版本,但是并没看到。
-----------
yum check-update mysql-server
可以检查可用的安装包

4.升级MySQL及其组件

yum update mysql-server
执行结束,会显示complete之类的关键字。

5.检查是否更新成功

mysql --version
当然,执行完这一步并不代表已经可以用MySQL了。在这里,可能碰到了一个错误。

问题1:

启动服务的时候,提示找不到mysql.sock之类的问题。

解决方案:

1.查看错误日志(前提:my.cnf里面有配置日志功能log-error = 路径)
cat /var/log/mysql_error.log
2.发现skip-locking5.6不支持,已经过时。改为skip-extenal-locking
(skip-locking可参考链接:) 
3.保存退出,重启mysqld服务即可

问题2:

启动服务的时候,错误日志显示Unknown/unsupported storage engine: InnoDB

解决方案:

执行删除命令:rm -rf /var/lib/mysql/ib*
删除:ibdata1、ib_logfile0、ib_logfile1文件
重启服务即可,service mysqld restart

当然,你可能会想,如果更新的版本存在5.5、5.6甚至更高,但我只是想更新到指定版本呢?那应该怎么做?

其实很简单,只要在上诉操作中更新前,改动repo配置文件即可。

配置文件路径:/etc/yum.repos.d
修改配置文件:mysql-community.repo和mysql-community-source.repo
修改内容:将所要更新的版本的enabled=1,其他版本的enabled=0即可,如下图所示,只更新到5.6版本:

image.png

【版权声明】本文为华为云社区用户原创内容,转载时必须标注文章的来源(华为云社区),文章链接,文章作者等基本信息,否则作者和本社区有权追究责任。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件至:cloudbbs@huaweicloud.com进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容。
  • 点赞
  • 收藏
  • 关注作者

评论(0

0/1000
抱歉,系统识别当前为高风险访问,暂不支持该操作

全部回复

上滑加载中

设置昵称

在此一键设置昵称,即可参与社区互动!

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。