PATA1027 Colors in Mars

举报
陈沧夜 发表于 2022/04/29 23:08:26 2022/04/29
【摘要】 1027 Colors in Mars People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, wh...

1027 Colors in Mars

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

 

Sample Output:

#123456
 

      #include<cstdio>
      #include<iostream>
      using namespace std;
      int main()
      {
     	const char a[13]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
     	int r,g,b;
     	scanf("%d%d%d%",&r,&g,&b);
     	printf("#");
     	printf("%c%c",a[r/13],a[r%13]);
     	printf("%c%c",a[g/13],a[g%13]);
     	printf("%c%c",a[b/13],a[b%13]);
     	return 0;
       }
  
 

 

文章来源: blog.csdn.net,作者:沧夜2021,版权归原作者所有,如需转载,请联系作者。

原文链接:blog.csdn.net/CANGYE0504/article/details/88836262

【版权声明】本文为华为云社区用户转载文章,如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@huaweicloud.com
  • 点赞
  • 收藏
  • 关注作者

评论(0

0/1000
抱歉,系统识别当前为高风险访问,暂不支持该操作

全部回复

上滑加载中

设置昵称

在此一键设置昵称,即可参与社区互动!

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。