PATA1058 A+B in Hogwarts
If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut
(Galleon
is an integer in [0,107], Sickle
is an integer in [0, 17), and Knut
is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
int G,S,K;
int Gs=0,Ss=0,Ks=0;
for(int i=0;i<2;i++)
{
scanf("%d.%d.%d",&G,&S,&K);
Gs+=G;
Ss+=S;
Ks+=K;
}
if(Ks>=29)
{
Ss=Ss+Ks/29;
Ks=Ks%29;
}
if(Ss>=17)
{
Gs=Gs+Ss/17;
Ss=Ss%17;
}
printf("%d.%d.%d",Gs,Ss,Ks);
return 0;
}
文章来源: blog.csdn.net,作者:沧夜2021,版权归原作者所有,如需转载,请联系作者。
原文链接:blog.csdn.net/CANGYE0504/article/details/88836383
- 点赞
- 收藏
- 关注作者
评论(0)