PATA1065 A+B and C (64bit)

举报
陈沧夜 发表于 2022/04/29 22:27:09 2022/04/29
【摘要】 1065 A+B and C (64bit) Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C. Input Specificati...

1065 A+B and C (64bit)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false
#include <cstdio> 
   
int main(){ 
    int n,i; 
    long long int a,b,c; 
   
    scanf("%d",&n); 
    for(i=1;i<=n;++i){ 
        bool flg = true; 
        scanf("%lld %lld %lld",&a,&b,&c); 
        long long res = a+b; 
        if(a>0 && b>0 && res<=0)flg = true; 
        else if(a<0 && b<0 && res>=0)flg = false; 
        else{ 
            if(res<=c)flg = false; 
        } 
        if(flg){ 
            printf("Case #%d: true\n",i); 
        }else{ 
            printf("Case #%d: false\n",i); 
        } 
    } 
    return 0; 
}

 

文章来源: blog.csdn.net,作者:沧夜2021,版权归原作者所有,如需转载,请联系作者。

原文链接:blog.csdn.net/CANGYE0504/article/details/88908752

【版权声明】本文为华为云社区用户转载文章,如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@huaweicloud.com
  • 点赞
  • 收藏
  • 关注作者

评论(0

0/1000
抱歉,系统识别当前为高风险访问,暂不支持该操作

全部回复

上滑加载中

设置昵称

在此一键设置昵称,即可参与社区互动!

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。