Cannot find component java in apiVersion 6(其实是Harmony SDK的版本)

黄生 发表于 2022/02/28 14:28:48 2022/02/28
【摘要】 DevEco使用的是2.1Release版本,因为平时用的不多,所以没有升级。那么在试用亲子早教这个例子时,就出现问题了。Cannot find component java in apiVersion 6其实当你看到有JAVA,有apiVersion 6,可能会以为是JAVA JDK的版本。其实不是。是Harmony的SDK里的JAVA语言SDK的版本,看所以,还是升级DevEco吧,虽然...

DevEco使用的是2.1Release版本,因为平时用的不多,所以没有升级。
那么在试用亲子早教这个例子时,就出现问题了。
image.png
Cannot find component java in apiVersion 6
其实当你看到有JAVA,有apiVersion 6,可能会以为是JAVA JDK的版本。
其实不是。
是Harmony的SDK里的JAVA语言SDK的版本,看
image.png
所以,还是升级DevEco吧,虽然手机是HarmonyOS2.0,但是显然IDE是可以向下支持的,还等什么呢
image.png
于是,下载、卸载、安装。
这时有点小小的烦恼,那就是SDK有2个需要你选择,
为什么会这样呢?应该是因为华为将鸿蒙(HarmonyOS)捐献了出来,形成了开源的鸿蒙(openHarmony)。选择安装JAVA API6。
image.png
然后重新编译亲子早教项目,就成功了。
image.png

【版权声明】本文为华为云社区用户原创内容,转载时必须标注文章的来源(华为云社区),文章链接,文章作者等基本信息,否则作者和本社区有权追究责任。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件至:cloudbbs@huaweicloud.com进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容。
  • 点赞
  • 收藏
  • 关注作者

评论(0

0/1000
抱歉,系统识别当前为高风险访问,暂不支持该操作

全部回复

上滑加载中

设置昵称

在此一键设置昵称,即可参与社区互动!

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。