1.5.1 整数奇偶数排序
【摘要】
Description
给定10个整数的序列,要求对其重新排序。排序要求:1.奇数在前,偶数在后;2.奇数按从大到小排序;3.偶数按从小到大排序。
Input
输入一行,包含10个整数,彼此以一个空格分开,每个整数的范围是大于等于0,小于等于100。
Output
按照要求排序后输出一...
Description
给定10个整数的序列,要求对其重新排序。排序要求:1.奇数在前,偶数在后;2.奇数按从大到小排序;3.偶数按从小到大排序。
Input
输入一行,包含10个整数,彼此以一个空格分开,每个整数的范围是大于等于0,小于等于100。
Output
按照要求排序后输出一行,包含排序后的10个整数,数与数之间以一个空格分开。
Sample Input 1
4 7 3 13 11 12 0 47 34 98
Sample Output 1
47 13 11 7 3 0 4 12 34 98
-
#include<bits/stdc++.h>
-
using namespace std;
-
-
int a[10],b[10],t1,t2,x;
-
bool compare(int a,int b)
-
{
-
return a>b;
-
}
-
int main(){
-
-
for(int i=0;i<10;i++){
-
scanf("%d",&x);
-
if(x%2==0){
-
-
b[t2++]=x;
-
-
}
-
else{
-
a[t1++]=x;
-
}
-
}
-
-
sort(a,a+t1,compare);
-
sort(b,b+t2);
-
for (int i = 0; i < t1; i ++ )printf("%d ",a[i]);
-
for (int i = 0; i < t2; i ++ )printf("%d ",b[i]);
-
}
数据量很小,就是看一下sort的降序用法而已。
文章来源: blog.csdn.net,作者:irrationality,版权归原作者所有,如需转载,请联系作者。
原文链接:blog.csdn.net/weixin_54227557/article/details/120584653
【版权声明】本文为华为云社区用户转载文章,如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱:
cloudbbs@huaweicloud.com
- 点赞
- 收藏
- 关注作者
评论(0)