POJ 3311 Hie with the Pie (弗洛伊德/TSP/状态压缩)

举报
楚楚冻人玥玥仙女 发表于 2021/11/19 03:09:44 2021/11/19
【摘要】 Hie with the Pie (POJ3311) Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 8639 Accepted:...

Hie with the Pie (POJ3311)

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8639 Accepted: 4722
Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0
Sample Output

8

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n;
int dp[1<<11][12];
int dis[12][12];
int ans;
int main(){
    while(~scanf("%d",&n)&&n){
        for(int i = 0; i <= n; i++){
            for(int j = 0; j <= n; j++){
                scanf("%d",&dis[i][j]);
            }
        }
        //弗洛伊德算法计算两点间的最短距离
        for(int k = 0; k <= n; k++){
            for(int i = 0; i <= n; i++){
                for(int j = 0; j <= n; j++){
                    if(dis[i][k] + dis[k][j] < dis[i][j]){
                        dis[i][j] = dis[i][k] + dis[k][j];
                    }
                }
            }
        }
        for(int state = 0; state < (1 << n); state ++){//枚举所有状态,用位运算表示
            for(int i = 1; i <= n; i++){
                if(state & (1<<(i-1))){//状态state中已经经过城市i
                    if(state == (1<<(i-1))){状态State只经过城市i,最优解自然是从0出发到i的dis,这也是DP的边界
                        dp[state][i] = dis[0][i];
                    }
                    else{//如果state经过多个城市
                        dp[state][i] = 0x7fffffff;
                        for(int j = 1; j <= n; j++){
                            if(state&(1<<(j-1)) && j!=i ){
                                dp[state][i] = min(dp[state][i],dp[state^(1<<(i-1))][j]+dis[j][i]);
                            }
                        }
                    }
                }
            }
        }
        ans = dp[(1<<n)-1][1]+dis[1][0];
        for(int i =2; i <= n; i++){
            ans = min(ans,dp[(1<<n)-1][i]+dis[i][0]);//从i点回到0点
        }
        printf("%d\n",ans);
    }
    return 0;
}

  
 
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52

文章来源: blog.csdn.net,作者:爱玲姐姐,版权归原作者所有,如需转载,请联系作者。

原文链接:blog.csdn.net/jal517486222/article/details/79357740

【版权声明】本文为华为云社区用户转载文章,如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@huaweicloud.com
  • 点赞
  • 收藏
  • 关注作者

评论(0

0/1000
抱歉,系统识别当前为高风险访问,暂不支持该操作

全部回复

上滑加载中

设置昵称

在此一键设置昵称,即可参与社区互动!

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。