[网络]路由BGP
路由
静态路由:用于小规模内网环境,死板不灵活,单向
动态路由:用于大规模网络环境,自动学习,灵活,需要占用一定的带宽资源
常见的动态路由协议
内部网关协议:rip ospf is-is igrp eigrp
外部网关协议:BGP自治系统编号:1-65535
1-65511 公有AS
65512-65535 私有AS
BGP:border gateway protocal,边界网关协议
类型:距离矢量路由协议
作用:连接不同的自治系统(AS),解决AS之间的选路问题,更适合互联网,无路由环
BGP的特征
tcp 179
外部路由协议,实现AS之间路由传递
距离矢量路由协议
可靠的路由更新机制
丰富的Metric度量方法
无路由环
可为路由条目附带多种属性信息
支持CIDR(无类别域间选路)
丰富的路由过滤和策略
非周期性更新
路由更新只发增量路由
周期性发送keepalive报文,保持tcp连通
BGP的5报文
- open:建立BGP对等体之间的连接
- update:更新增量路由
- notification:检测错误状态,报错
- route-refresh:告知对等体本地支持的路由刷新能力
- keepalive:周期性发送,保持有效连接
BGP的6状态机
- idle:初始状态,拒绝任何连接
- connect:连接态,等待tcp连接的建立
- active:活跃态,尝试tcp连接
- opensent:检查态,检查收到的open报文,如果报文正确转到下一连接状态openconfirm;如果报文错误,转到idle
- openconfirm:等待态,等待对等体的keepalive或notification报文,如果是keepalive就进入到established;如果是notification就回到idle
- established:建立态,对等体之间正常收发信息
BGP的5表
- IP路由表(IP-RIB):全局路由信息库,包含所有最优的ip路由信息
- BGP路由表(Loc-RIB):本地bgp speaker通告的路由信息,选其中最优添加到ip路由表
- 邻居表:邻居清单列表
- Adi-RIB-In:对等体宣告的未处理的路由信息
- Adi-RIB-Out:本地宣告给对等体的路由信息
BGP邻居关系类型
IBGP:一个AS内部的BGP邻居关系
EBGP:AS之间的BGP邻居关系
命令:
bgp 200 #宣告自己的自治系统编号
router-id 2.2.2.2 #宣告自己的路由器id
peer 12.1.1.1 as-number 100 #和谁(对等体ip及AS号码)建立bgp邻居关系
通告BGP路由的方法
network:network命令发布,一般直接发布路由到bgp
命令:
bgp 100
router-id 1.1.1.1
peer 12.0.0.2 as-number 100
network 1.1.1.1 32
network 2.2.2.2 32
Import:一般用于把其他路由协议的路由信息导入到bgp
命令:
import-route ospf 110
BGP属性
origin:起源
AS-path:到达目的经过的AS编号
next-hop:路由下一跳信息
local-pref:标识bgp路由的优先级,默认100,值越高越优先
med:判断流量进入邻居AS时的最佳路由,默认0,值越小越优先
BGP选路原则
目标路由下一跳不可达,则忽略
preferred-value值高者优先
local-preference值高者优先
聚合路由高于非聚合路由
手动聚合高于自动聚合
network注入高于import导入
AS路径值少者优先
比较origin:IGP>EGP>imcomplete
med值小者优先
EBGP优先IBGP
练习
某企业因为业务需求,要使运营商网络(R1:1.1.1.1)和公司(R4:4.4.4.4)网络路由可达。需要在所有router间运行BGP协议,r1和r2、r3之间建立ebgp连接,r2、r3和r4之间建立ibgp全连接。运营商网络为as100,公司网络为as200,在as200内,使用igp协议来计算路由(该例使用ospf作为igp协议)
需求:
要求实现两个as之间的互相通信(192.168.1.0与192.168.2.0)
As 200内部通过ospf互相通信
通过修改bgp属性使实现业务需求的路径从r2切换到r3
R1
<Huawei>sys
[huawei]undo info enable
[huawei]sysname r1
[r1]interface GigabitEthernet0/0/0
[R1-GigabitEthernet0/0/0]ip address 10.0.12.1 255.255.255.0
[r1]interface GigabitEthernet0/0/1
[R1-GigabitEthernet0/0/0]ip address 10.0.13.1 255.255.255.0
r1]interface GigabitEthernet0/0/2
[R1-GigabitEthernet0/0/2]ip address 192.168.1.1 255.255.255.0
[r1]interface LoopBack 0
[R1-LoopBack0]ip address 1.1.1.1 255.255.255.255
[R1-LoopBack0]quit
[r1]bgp 100
[R1-bgp]router-id 1.1.1.1
[R1-bgp]peer 10.0.12.2 as-number 200
[R1-bgp]peer 10.0.13.3 as-number 200
[R1-bgp]network 1.1.1.1 32
[R1-bgp]network 192.168.1.0 24
R2
[huawei]sysname r2
[r2]interface GigabitEthernet0/0/0]ip address 10.0.12.2 255.255.255.0
[r2]interface GigabitEthernet0/0/1
[R2-GigabitEthernet0/0/2]ip address 10.0.24.2 255.255.255.0
[r2]interface LoopBack 0
[R2-LoopBack0]ip address 2.2.2.2 255.255.255.255
[R2-LoopBack0]quit
[r2]bgp 200
[R2-bgp]router-id 2.2.2.2
[R2-bgp]peer 10.0.12.1 as-number 100
[R2-bgp]peer 10.0.24.4 as-number 200
[R2-bgp]peer 10.0.24.4 next-hop-local
[R2-bgp]quit
[r2]ospf 110
[R2-ospf-110]area 0.0.0.0
[R2-ospf-110]network 10.0.24.0 0.0.0.255
[R2-ospf-110]network 2.2.2.2 0.0.0.0
R3
<Huawei>sys
[huawei]undo info enable
[huawei]sysname r3
[r3]interface GigabitEthernet0/0/0]ip address 10.0.13.3 255.255.255.0
[r3]interface GigabitEthernet0/0/1
[R3-GigabitEthernet0/0/2]ip address 10.0.34.3 255.255.255.0
[r3]interface LoopBack 0
[R3-LoopBack0]ip address 3.3.3.3 32
[R3-LoopBack0]quit
[r3]bgp 200
[R3-bgp]router-id 3.3.3.3
[R3-bgp]peer 10.0.13.1 as-number 100
[R3-bgp]peer 10.0.34.4 as-number 200
[R3-bgp]peer 10.0.34.4 next-hop-local
[R3-bgp]quit
[R3]ospf 110
[R3-ospf-110]area 0.0.0.0
[R3-ospf-110]network 10.0.34.0 0.0.0.255
[R3-ospf-110]network 3.3.3.3 0.0.0.0
R4
<Huawei>sys
[huawei]undo info enable
[huawei]sysname r4
[r4]interface GigabitEthernet0/0/0]ip address 10.0.24.4 255.255.255.0
[r4]interface GigabitEthernet0/0/1
[R4-GigabitEthernet0/0/2]ip address 10.0.34.4 255.255.255.0
[r4]interface GigabitEthernet0/0/2
[R4-GigabitEthernet0/0/2]ip address 192.168.2.1 255.255.255.0
[r4]interface LoopBack 0
[R4-LoopBack0]ip address 4.4.4.4 255.255.255.255
[R4-LoopBack0]quit
[r4]bgp 200
[R4-bgp]router-id 4.4.4.4
[R4-bgp]peer 10.0.24.2 as-number 200
[R4-bgp]peer 10.0.34.3 as-number 200
[R4-bgp]network 4.4.4.4 32
[R4-bgp]network 192.168.2.0 24
[R4-bgp]peer 10.0.34.3 next-hop-local
[R4-bgp]peer 10.0.24.2 next-hop-local
[R4-bgp]quit
[R4]ospf 110
[R4-ospf-110]area 0.0.0.0
[R4-ospf-110]network 4.4.4.4 0.0.0.0
[R4-ospf-110]network 10.0.34.0 0.0.0.255
[R4-ospf-110]network 10.0.24.0 0.0.0.255
[R4-ospf-110]network 192.168.2.0 0.0.0.255
查看配置
R4
[R4]disp bgp routing-table
BGP Local router ID is 4.4.4.4
Status codes: * - valid, > - best, d - damped,
h - history, i - internal, s - suppressed, S - Stale
Origin : i - IGP, e - EGP, ? - incomplete
Total Number of Routes: 5
Network NextHop MED LocPrf PrefVal Path/Ogn
*>i 1.1.1.1/32 10.0.24.2 0 100 0 100i
* i 10.0.34.3 0 100 0 100i
*>i 2.2.2.2/32 10.0.24.2 0 100 0 i
*>i 3.3.3.3/32 10.0.34.3 0 100 0 i
*> 4.4.4.4/32 0.0.0.0 0 0 i
左右两台pc机填写ip,看是否能相互ping通
在r3上修改local-preference值
[r3]route-policy lop permit node 10
[r3-route-policy]apply local-preference 222
[r3]bgp 200
[r3-bgp]peer 10.0.34.4 route-policy lop export
[r3-bgp]quit
[r3]quit
<r3>reset bgp all
<R4>dis bgp routing-table
BGP Local router ID is 4.4.4.4
Status codes: * - valid, > - best, d - damped,
h - history, i - internal, s - suppressed, S - Stale
Origin : i - IGP, e - EGP, ? - incomplete
Total Number of Routes: 4
Network NextHop MED LocPrf PrefVal Path/Ogn
*>i 1.1.1.1/32 10.0.34.3 0 222 0 100i
*>i 2.2.2.2/32 10.0.24.2 0 100 0 i
*>i 3.3.3.3/32 10.0.34.3 0 222 0 i
*> 4.4.4.4/32 0.0.0.0 0 0 i
修改as-path属性
为了还原最初走r2的的效果,请先清除第1)步的配置,在bgp进程中删除策略调用语句
[R3]bgp 200
[R3-bpg]undo peer 10.0.34.4 route-policy lop export
在r2上修改as-path属性并传出个r4
[R2]route-policy as permit node 10
[R2-route-policy]apply as-path 123 123 123 additive
[R2-route-policy]quit
[R2]bgp 200
[R2-bgp]peer 10.0.24.4 route-policy as export
[r2-bgp]quit
[r2]quit
<r2>reset bgp all
通过med属性控制路由
R1到r4的默认路径为r1—r2—r4
<R1>disp bgp routing-table
BGP Local router ID is 1.1.1.1
Status codes: * - valid, > - best, d - damped,
h - history, i - internal, s - suppressed, S - Stale
Origin : i - IGP, e - EGP, ? - incomplete
Total Number of Routes: 7
Network NextHop MED LocPrf PrefVal Path/Ogn
*> 1.1.1.1/32 0.0.0.0 0 0 i
*> 2.2.2.2/32 10.0.12.2 0 0 200i
* 10.0.13.3 0 200 123 12
3 123i
*> 3.3.3.3/32 10.0.12.2 0 200i
* 10.0.13.3 0 0 200i
*> 4.4.4.4/32 10.0.12.2 0 200i
* 10.0.13.3 0 200i
修改为r1—r3----r4
在r2上进行修改MED属性并传出给r1,可以使r1去往r4的路由改走r3
[R2]route-policy med permit node 10
[R2-route-policy]apply cost + 500
[R2-route-policy]quit
[R2]bgp 200
[R2-bgp]peer 10.0.12.1 route-policy med export
[R2-bgp]quit
<R1>disp bgp routing-table
BGP Local router ID is 1.1.1.1
Status codes: * - valid, > - best, d - damped,
h - history, i - internal, s - suppressed, S - Stale
Origin : i - IGP, e - EGP, ? - incomplete
Total Number of Routes: 7
Network NextHop MED LocPrf PrefVal Path/Ogn
*> 1.1.1.1/32 0.0.0.0 0 0 i
*> 2.2.2.2/32 10.0.12.2 500 0 200i
* 10.0.13.3 0 200 123 12
3 123i
*> 3.3.3.3/32 10.0.13.3 0 0 200i
* 10.0.12.2 500 0 200i
*> 4.4.4.4/32 10.0.13.3 0 200i
* 10.0.12.2 500 0 2
- 点赞
- 收藏
- 关注作者
评论(0)