HDU - 1212 Big Number(JAVA)

举报
用户已注销 发表于 2021/11/19 06:27:56 2021/11/19
【摘要】 题目: Description As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate...
题目:

Description

As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B. 

To make the problem easier, I promise that B will be smaller than 100000. 

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines. 

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file. 

Output

For each test case, you have to ouput the result of A mod B. 

Sample Input

2 3
12 7
152455856554521 3250

Sample Output

2
5
1521
 
  
这个题目很简单,就是输入a,b 输出a%b
因为a很大,所以要用到Java的大数类
代码:
import java.util.*;
import java.math.BigInteger;
public class Main {

    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        String s;
        while(cin.hasNext())
        {
        	s=cin.next();
        	BigInteger a=new BigInteger(s);
        	s=cin.next();
        	BigInteger b=new BigInteger(s);      
            a=a.mod(b);
            System.out.println(a.toString());
        }        
    }
}

文章来源: blog.csdn.net,作者:csuzhucong,版权归原作者所有,如需转载,请联系作者。

原文链接:blog.csdn.net/nameofcsdn/article/details/52818116

【版权声明】本文为华为云社区用户转载文章,如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@huaweicloud.com
  • 点赞
  • 收藏
  • 关注作者

评论(0

0/1000
抱歉,系统识别当前为高风险访问,暂不支持该操作

全部回复

上滑加载中

设置昵称

在此一键设置昵称,即可参与社区互动!

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。