素数环
【摘要】 Prime Ring Problem
Time Limit : 4000/2000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 18 Accepted Submission(s) : 12
F...
Prime Ring Problem
Time Limit : 4000/2000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 18 Accepted Submission(s) : 12
Font: Times New Roman |Verdana |Georgia
Font Size: ← →
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
Source
Asia 1996, Shanghai (Mainland China)
代码:
-
#include <stdio.h>
-
#include <string.h>
-
int n,ac[21]={1};
-
bool in[21];
-
bool is_prime(int x)
-
{
-
for(int i=2;i*i<=x;i++)
-
if(x%i==0)
-
return false;
-
return true;
-
}
-
void dfs(int cur)
-
{
-
if(cur == n-1)
-
{
-
if(is_prime(ac[cur]+1))
-
{
-
printf("1");
-
for(int i=1;i<n;i++)
-
printf(" %d",ac[i]);
-
printf("\n");
-
}
-
return ;
-
}
-
for(int i=2;i<=n;i++)
-
{
-
if(!in[i] && is_prime(i+ac[cur]))
-
{
-
in[i]=1;
-
ac[cur+1]=i;
-
dfs(cur+1);
-
in[i]=0;
-
}
-
}
-
}
-
int main()
-
{
-
int ncase=0;
-
while(scanf("%d",&n),n)
-
{
-
printf("Case %d:\n",++ncase);
-
memset(in,0,sizeof(in));
-
if(n%2==0 || n==1)
-
dfs(0);
-
else
-
printf("No Answer\n");
-
}
-
return 0;
-
}
文章来源: blog.csdn.net,作者:Linux猿,版权归原作者所有,如需转载,请联系作者。
原文链接:blog.csdn.net/nyist_zxp/article/details/9148191
【版权声明】本文为华为云社区用户转载文章,如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱:
cloudbbs@huaweicloud.com
- 点赞
- 收藏
- 关注作者
评论(0)