HDOJ 2012 素数判定
【摘要】 Problem Description 对于表达式n^2+n+41,当n在(x,y)范围内取整数值时(包括x,y)(-39<=x < y<=50),判定该表达式的值是否都为素数。
Input 输入数据有多组,每组占一行,由两个整数x,y组成,当x=0,y=0时,表示输入结束,该行不做处理。
Output 对于每个给定范围内的取值,如果表达式的值都为素数,则输出...
Problem Description
对于表达式n^2+n+41,当n在(x,y)范围内取整数值时(包括x,y)(-39<=x < y<=50),判定该表达式的值是否都为素数。
Input
输入数据有多组,每组占一行,由两个整数x,y组成,当x=0,y=0时,表示输入结束,该行不做处理。
Output
对于每个给定范围内的取值,如果表达式的值都为素数,则输出”OK”,否则请输出“Sorry”,每组输出占一行。
Sample Input
0 1
0 0
Sample Output
OK
import java.util.Scanner;
class Main{
public static void main(String args[]){ Scanner sc = new Scanner(System.in); while(sc.hasNext()){ int x = sc.nextInt(); int y = sc.nextInt(); if(x==0&&y==0) return ; int flag = 0; for(int i=x;i<=y;i++){ if(!susu(i*i+i+41)){ System.out.println("Sorry"); flag=1; break; } } if(flag==0) System.out.println("OK"); }
}
public static boolean susu(int n ){
//判断n是否是素数,是素数返回true for(int i=2;i*i<=n;i++){ if(n%i==0) return false; } return true;
}
}
- 1
- 2
- 3
- 4
- 5
- 6
- 7
- 8
- 9
- 10
- 11
- 12
- 13
- 14
- 15
- 16
- 17
- 18
- 19
- 20
- 21
- 22
- 23
- 24
- 25
- 26
- 27
- 28
- 29
- 30
文章来源: chenhx.blog.csdn.net,作者:谙忆,版权归原作者所有,如需转载,请联系作者。
原文链接:chenhx.blog.csdn.net/article/details/49686713
【版权声明】本文为华为云社区用户转载文章,如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱:
cloudbbs@huaweicloud.com
- 点赞
- 收藏
- 关注作者
评论(0)