POJ 1423 Big Number

举报
谙忆 发表于 2021/05/27 19:11:16 2021/05/27
【摘要】 Description In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem yo...

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.
Output

The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input

2
10
20
Sample Output

7
19

(部分转载)
补充知识 :若n=a+b^10,(a<1,b∈N),则n的位数为b。
所以要求一个数字num有多少位,可以用(int)log10(num)+1,这样就求出num有多少位.
如果sum=n*(n-1)(n-2)……*1,那么log10(sum)=log10(n)+
log10(n-1)+…..+log10(2)+log10(1)。即sum的位数是
( int )( log10(n)+log10(n-1)+…..+log10(2)+log10(1) )+1。
(从小到大算)

下面这一种方法是程序外打表法,需要消耗时间。
还有一种是程序外打表,就是直接给复制,再导入,则肯定是0ms。

#include <stdio.h>
#include <math.h>

int a[10000010];
int main()
{ double d; int i; int t; int n; for(i=1,d=0;i<10000005;i++){ d+=log10(i); a[i]=(int)d+1; } scanf("%d",&t); while(t-->0){ scanf("%d",&n); printf("%d\n",a[n]); } return 0;
}

  
 
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24

还有一种方法:
利用Stirling公式. n!≈sqrt(2*pi*n)*[(n/e)^n]
n越大,答案越准确。
在n=1的情况下,也最大不过相差0.2.
这里只要计算位数,所以是可以用的。
此处的:
e ≈ 2.7182818284590452354, pi ≈ 3.141592653589793239;

#include<iostream>
#include<cmath>
using namespace std;
const double e = 2.7182818284590452354, pi = 3.141592653589793239;
double strling_digits_num(int n)
{ return log10(2*pi*n)/2.0+n*(log10(n/e));
}

int main()
{ int t; cin>>t; while(t--) { int n; cin>>n; double m=0; m=strling_digits_num(n); int answer=(int)m; answer++; cout<<answer<<endl; } return 0;
}

  
 
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26

文章来源: chenhx.blog.csdn.net,作者:谙忆,版权归原作者所有,如需转载,请联系作者。

原文链接:chenhx.blog.csdn.net/article/details/49765361

【版权声明】本文为华为云社区用户转载文章,如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@huaweicloud.com
  • 点赞
  • 收藏
  • 关注作者

评论(0

0/1000
抱歉,系统识别当前为高风险访问,暂不支持该操作

全部回复

上滑加载中

设置昵称

在此一键设置昵称,即可参与社区互动!

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。