云社区 博客 博客详情
云社区 博客 博客详情

【技术教程】IDE插件的安装依赖问题解决方案

Welink官方小助手 发表于 2020-04-07 17:49:56 04-07 17:49
Welink官方小助手 发表于 2020-04-07 17:49:56 2020/04/07
1
1

【摘要】 IDE插件的安装依赖问题解决方案



问题描述使用IDE插件功能时,提示wlk-cli不是外部命令,导致无法使用初始化、本地调试、真机调试、上传、设置等功能。

 

解决方案

原因:IDE插件加载项目时,默认会检查是否安装了yarn,如果存在,则使用yarn进行安装。否则使用npm安装依赖。如果初始化使用了yarn安装依赖,但新增包时又使用了npm,会造成依赖冲突。


解决:

  重新安装下依赖包:yarn 或者 npm install。

  但新增包时,需要注意下。

  如果已安装yarn,使用yarn add 命令,如:

  yarn add loadsh

  无yarn时,使用npm安装:

  npm install loadsh



登录后可下载附件,请登录或者注册

【版权声明】本文为华为云社区用户原创内容,转载时必须标注文章的来源(华为云社区),文章链接,文章作者等基本信息,否则作者和本社区有权追究责任。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件至:huaweicloud.bbs@huawei.com进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容。
评论文章 //点赞 收藏 1
点赞
分享文章到微博
分享文章到朋友圈

评论 (1)


Welink官方小助手

1楼2020-04-07 17:50:37
来咯, 技术干货分享,自提
0/1000
评论

登录后可评论,请 登录注册

评论

您还没有写博客的权限!

温馨提示

您确认删除评论吗?

确定
取消
温馨提示

您确认删除评论吗?

删除操作无法恢复,请谨慎操作。

确定
取消
温馨提示

您确认删除博客吗?

确定
取消

确认删除

您确认删除博客吗?

确认删除

您确认删除评论吗?

温馨提示

登录超时或用户已下线,请重新登录!!!

确定
取消