建议使用以下浏览器,以获得最佳体验。 IE 9.0+以上版本 Chrome 31+ 谷歌浏览器 Firefox 30+ 火狐浏览器
请选择 进入手机版 | 继续访问电脑版
设置昵称

在此一键设置昵称,即可参与社区互动!

确定
我再想想
选择版块
标签
您还可以添加5个标签
  • 没有搜索到和“关键字”相关的标签
  • 云产品
  • 解决方案
  • 技术领域
  • 通用技术
  • 平台功能
取消

Yesterday

发帖: 6粉丝: 0

发消息 + 关注

发表于2020年07月13日 15:16:12 807 3
直达本楼层的链接
楼主
显示全部楼层
[问题求助] Ubuntu 20.04下从源代码编译r0.5版无法生成whl文件

最近打算开始学习使用Mindspore,从官网上发现Mindspore要求使用Python3.7.5以上的版本,而我之前使用的Ubuntu18.04原生只支持到Python3.6.9,所以我就把体系升级到了Ubuntu20.04,Python也自动升级到Python3.8.2。但是在使用Pip进行安装时却显示“mindspore-0.5.0-cp37-cp37m-linux_x86_64.whl is not a supported wheel on this platform”:

pip3 install https://ms-release.obs.cn-north-4.myhuaweicloud.com/0.5.0-beta/MindSpore/cpu/ubuntu_x86/mindspore-0.5.0-cp37-cp37m-linux_x86_64.whl
Defaulting to user installation because normal site-packages is not writeable
ERROR: mindspore-0.5.0-cp37-cp37m-linux_x86_64.whl is not a supported wheel on this platform.

我觉得可能是ubuntu版本有问题,所以尝试从源代码进行安装。按照官网上的说明,先从Gitee上下载源代码:

git clone https://gitee.com/mindspore/mindspore.git -b r0.5

然后再进行编译:

bash build.sh -e cpu -j4

第一次编译报错,我看了一下系统默认的C/C++编译器是GCC 9,而官网上用的是GCC 7。于是我又把编译器改成GCC 7重新编译,这次没有报错,貌似编译成功了:

...
[100%] Built target _c_mindrecord
[100%] Built target inference
[100%] Built target _c_dataengine
Run CPack packaging tool...
CPack: Create package using External
CPack: Install projects
CPack: - Clean temporary : /home/isaac/Downloads/mindspore/build/package/mindspore
CPack: - Run preinstall target for: MindSpore
CPack: - Install project: MindSpore []
CPack: Create package
-- Found Python3: /usr/bin/python3.8 (found suitable version "3.8.2", minimum required is "3.7") found components: Interpreter Development 
-- Found Git: /usr/bin/git (found version "2.25.1") 
Could not find 'Python 3.7'
CPack: - package: /home/isaac/Downloads/mindspore/build/mindspore/mindspore generated.
success to build mindspore project!
---------------- mindspore: build end   ----------------

这里有有一个“Could not find 'Python 3.7'”的提示,不过最后还是显示“success to build mindspore project!”。

按照官网上的说明,按说下一步应该是给生成的whl文件权限之后就可以安装了:

chmod +x build/package/mindspore-{version}-cp37-cp37m-linux_{arch}.whl
pip install build/package/mindspore-{version}-cp37-cp37m-linux_{arch}.whl

可问题是,我发现我的build/package目录下面只有一个mindspore的文件夹,并没有这么一个whl文件,也就无法进行下一步操作。

所以我想请问一下,如何才能生成whl文件从而进一步安装Mindspore?

举报
分享

分享文章到朋友圈

分享文章到微博

埼玉

发帖: 65粉丝: 16

发消息 + 关注

发表于2020年07月13日 15:48:23
直达本楼层的链接
沙发
显示全部楼层

你好,我们的Python版本要求是3.7.5,不是3.7.5以上哦!虽然可能某些版本能使用,但是某些方面还是不支持的

whl文件下载地址:https://www.mindspore.cn/versions根据自己的设备和版本来选取相应的whl文件哦

评论
Yesterday 2020-7-13 15:52 评论

问题是我是从源代码编译的,而且编译结果也成功了,理论上不应该不支持。而且现在的问题是没有生成whl文件,如果生成的whl文件无法安装才真正说明不支持。

... 查看全部
dev_lsa 2020-7-18 11:33 评论

打包脚本里面写了强依赖python3.7版本,python3.8的版本是不符合要求的。

... 查看全部
Yesterday 2020-7-20 12:35 评论

评论 dev_lsa:我后来把cmake/package_script.cmake里面的python3.7改成python3.8之后,是可以正常打包使用的。

... 查看全部
点赞 评论 引用 举报

埼玉

发帖: 65粉丝: 16

发消息 + 关注

发表于2020年07月15日 09:11:40
直达本楼层的链接
板凳
显示全部楼层

你好,专家帮您复现了一下,MindSpore目前是强依赖于python3.7版本的,python3.8的版本是不符合要求的哦。

这个success其实就是个误报,我们已经在修改了

同时邀请您参与本月的论坛活动,可以赢取精美小礼品的,感谢对MindSpore的关注呢!


评论
Yesterday 2020-7-20 12:34 评论

我后来研究了一下,其实就是你们给强行限制在python 3.7了,我把cmake/package_script.cmake里面的python3.7改成python3.8之后,是可以正常打包使用的,所以说都编译成功了还不能用就真奇了怪了。

... 查看全部
点赞 评论 引用 举报

埼玉

发帖: 65粉丝: 16

发消息 + 关注

发表于2020年07月20日 15:46:09
直达本楼层的链接
地板
显示全部楼层

回复:埼玉 发表于 2020-7-15 09:11 你好,专家帮您复现了一下,MindSpore目前是强依赖于python3.7版本的,python3.8的版本是不符合要求的哦。这个success其实就是个误报,

是这样的,目前的开发都是基于3.7的,我们目前全力保证在3.7的基础上各平台都能正常使用,其他版本能不能使用我们暂时不去关注,如果出了问题我们也没有办法及时调动人力去修复,所以限制了3.7。那个报success真的是个误报,上周六已经修复这个问题啦。不过您定位问题还是很666的,感谢关注哈!

点赞 评论 引用 举报

游客

富文本
Markdown
您需要登录后才可以回帖 登录 | 立即注册