建议使用以下浏览器,以获得最佳体验。 IE 9.0+以上版本 Chrome 31+ 谷歌浏览器 Firefox 30+ 火狐浏览器
请选择 进入手机版 | 继续访问电脑版
设置昵称

在此一键设置昵称,即可参与社区互动!

确定
我再想想
选择版块
092713ie8gnff9tx2p8m72.jpg 体验鲲鹏开发套件 汇聚鲲鹏领域技术专家大咖 华为云云享专家发展计划

斯坦李@银河护卫队

发帖: 12粉丝: 1

级别 : 新手上路

发消息 + 关注

发表于2020-5-28 19:12:57 150 1
直达本楼层的链接
楼主
显示全部楼层
[大数据] Ambari-2.7.3.0-139 (CentOS 7.6) 编译失败,访问不了Atlassian maven仓

【问题描述】

在CentOS 7.6 环境中,编译Ambari-2.7.3.0-139 时,编译Ambari Server报错,看报错信息是获取atlassian的maven仓失败,自己在环境中也访问https://maven.atlassian.com/repository/public也显示404.

image.png

报错信息:

[ERROR] Failed to execute goal org.codehaus.mojo:xml-maven-plugin:1.0:transform (default) on project ambari-server

: Execution default of goal org.codehaus.mojo:xml-maven-plugin:1.0:transform failed: Plugin org.codehaus.mojo:xml-

maven-plugin:1.0 or one of its dependencies could not be resolved: Could not transfer artifact com.google.code.fin

dbugs:findbugs:jar:2.0.0 from/to maven2-repository.atlassian (https://maven.atlassian.com/repository/public): sun.

security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilde

rException: unable to find valid certification path to requested target -> [Help 1]


【问题原因】

Atlassian的maven仓URL已经发生变化,需要更新为 https://maven.atlassian.com/content/repositories/atlassian-public/


【解决方法】

在ambari-release-AMBARI-2.7.3.0-139-tag/pom.xml 中修改Atlassian Maven Repository 的URL,修改后如图下所示:

image.png

举报
分享

分享文章到朋友圈

分享文章到微博

阿奇@汪汪队

发帖: 58粉丝: 39

级别 : 版主

发消息 + 关注

发表于2020-5-28 19:16:47
直达本楼层的链接
沙发
显示全部楼层

很好!

点赞 评论 引用 举报

游客

富文本
Markdown
您需要登录后才可以回帖 登录 | 立即注册