建议使用以下浏览器,以获得最佳体验。 IE 9.0+以上版本 Chrome 31+ 谷歌浏览器 Firefox 30+ 火狐浏览器
请选择 进入手机版 | 继续访问电脑版
设置昵称

在此一键设置昵称,即可参与社区互动!

确定
我再想想
选择版块
标签
您还可以添加5个标签
  • 没有搜索到和“关键字”相关的标签
  • 云产品
  • 解决方案
  • 技术领域
  • 通用技术
  • 平台功能
取消

靖国

发帖: 1粉丝: 0

级别 : 合作伙伴

发消息 + 关注

发表于2020年05月10日 23:56:43 480 3
直达本楼层的链接
楼主
显示全部楼层
[大数据] hbase 1.1.5 编译过程中,ant 编译 jruby-complete-1.6.8.jar 的libjffi.so 报错

报错内容如下:

BUILD FAILED

 jruby-1.6.8/build.xml:673: The following error occurred while executing this line:

 jruby-1.6.8/build.xml:264: apt does not exist under Java 1.8 and higher

apt在java8发布时已经移除。

查看官网上的指导,https://support.huaweicloud.com/prtg-hdp-kunpengbds/kunpengambarihdp_02_0020.html,不知道为何,请参考《jruby-complete-1.6.8.jar移植指南》,这个链接失效,求指导。

举报
分享

分享文章到朋友圈

分享文章到微博

五湖四海@银河护卫队

发帖: 120粉丝: 45

级别 : 版主

发消息 + 关注

发表于2020年05月11日 09:31:47
直达本楼层的链接
沙发
显示全部楼层

针对jruby1.6.8的版本,网上有已经编译好的安装包,链接附上:

https://rubygems.org/gems/jruby-jars/versions/1.6.8

blob.png

直接进行下载,之后使用gem进行安装:gem install jruby-jars -v 1.6.8
安装就可以成功。


jruby-complete-1.6.8.jar移植可以参考:

https://bbs.huaweicloud.com/forum/thread-38009-1-1.html

点赞 评论 引用 举报

靖国

发帖: 1粉丝: 0

级别 : 合作伙伴

发消息 + 关注

发表于2020年05月11日 10:41:20
直达本楼层的链接
板凳
显示全部楼层

@五湖四海@银河护卫队,收到你的回复,针对https://bbs.huaweicloud.com/forum/thread-38009-1-1.html 有一点疑惑,希望可以解答。我先附上图片。

image.png

image.png

这两个链接库的名字都不一样,如何产生的?文中没有提起,请解惑?

点赞 评论 引用 举报

靖国

发帖: 1粉丝: 0

级别 : 合作伙伴

发消息 + 关注

发表于2020年05月15日 10:03:47
直达本楼层的链接
地板
显示全部楼层

后来问题解决了,方法是不要从官网下载hbase的源码进行编译,参考https://bbs.huaweicloud.com/forum/thread-41972-1-1.html,下载正确的hbase版本编译,可以绕过ant 编译时候报错,jdk 1.8 不支持apt 的问题,感谢版主的共享

点赞 评论 引用 举报

游客

富文本
Markdown
您需要登录后才可以回帖 登录 | 立即注册