建议使用以下浏览器,以获得最佳体验。 IE 9.0+以上版本 Chrome 31+ 谷歌浏览器 Firefox 30+ 火狐浏览器
请选择 进入手机版 | 继续访问电脑版
设置昵称

在此一键设置昵称,即可参与社区互动!

确定
我再想想
选择版块
标签
您还可以添加5个标签
  • 没有搜索到和“关键字”相关的标签
  • 云产品
  • 解决方案
  • 技术领域
  • 通用技术
  • 平台功能
取消

黎维彬

发帖: 2粉丝: 0

发消息 + 关注

发表于2020年06月24日 11:27:22 765 5
直达本楼层的链接
楼主
显示全部楼层
[问题求助] yolov3模型转失败

提示LeakyRelu操作类型不支持

image.png

举报
分享

分享文章到朋友圈

分享文章到微博

Tony.Chen

发帖: 0粉丝: 0

发消息 + 关注

发表于2020年06月24日 15:33:23
直达本楼层的链接
沙发
显示全部楼层

您好,请问这个是 tensorflow 的 pb 模型,还是 caffe 模型?

点赞 评论 引用 举报

捕虫少年

发帖: 4粉丝: 5

发消息 + 关注

发表于2020年07月03日 09:18:43
直达本楼层的链接
板凳
显示全部楼层

你好,请问问题还存在吗

点赞 评论 引用 举报

小猹狸

发帖: 6粉丝: 0

发消息 + 关注

发表于2020年11月12日 11:48:24
直达本楼层的链接
地板
显示全部楼层

回复:捕虫少年 发表于 2020-7-3 09:18 你好,请问问题还存在吗

您好,我也出现了同样的问题。我使用ONNX将pytorch的yolov3模型转换为了tensorflow的.pb模型。在Atlas 300平台上使用omg进行模型转换,显示“Unsupport op type LeakyRelu”。然而算子清单中有这一op。求各位大佬帮忙!

pytorch版yolov3我使用的https://github.com/ultralytics/yolov3

tensorflow-gpu版本1.15.0

pytorch版本1.7.0

onnx版本1.8.0

点赞 评论 引用 举报

捕虫少年

发帖: 4粉丝: 5

发消息 + 关注

发表于2020年11月12日 11:58:24
直达本楼层的链接
5#
显示全部楼层

回复:小猹狸 发表于 2020-11-12 11:48 您好,我也出现了同样的问题。我使用ONNX将pytorch的yolov3模型转换为了tensorflow的.pb模型。在Atlas 300平台上使用omg进行模

您好,可以发一下详细的报错截图吗,目前转onnx首批模型都还没有精度性能达标,后续会支持

点赞 评论 引用 举报

小猹狸

发帖: 6粉丝: 0

发消息 + 关注

发表于2020年11月13日 09:34:18
直达本楼层的链接
6#
显示全部楼层

回复:捕虫少年 发表于 2020-11-12 11:58 您好,可以发一下详细的报错截图吗,目前转onnx首批模型都还没有精度性能达标,后续会支持

昨天我在论坛里找了一下,发现可能是TensorFlow版本的原因导致的问题。但是我使用的onnx2tensorflow代码要求tensorflow版本为1.15.0,于是我就在pytorch中将网络里LeakyReLU换为了PReLU,之后就没有报这个算子不支持。

但后续又出现了一些问题。在Pytorch中使用Tensor.view操作和torch.cat操作经过onnx转换会在tensorflow的graph中分别生成SparseToDenseNoOp节点,而这两个节点用omg转换时都会报“Unsupport op type”。

noop.PNG

sparsetodense.PNG


我使用的网络中Tensor.view操作可以去掉,而torch.cat操作没找到替换的方法。感谢大佬帮忙!

点赞 评论 引用 举报

游客

富文本
Markdown
您需要登录后才可以回帖 登录 | 立即注册