建议使用以下浏览器,以获得最佳体验。 IE 9.0+以上版本 Chrome 31+ 谷歌浏览器 Firefox 30+ 火狐浏览器
请选择 进入手机版 | 继续访问电脑版
设置昵称

在此一键设置昵称,即可参与社区互动!

确定
我再想想
选择版块
直达楼层
标签
您还可以添加5个标签
  • 没有搜索到和“关键字”相关的标签
  • 云产品
  • 解决方案
  • 技术领域
  • 通用技术
  • 平台功能
取消

采纳成功

您已采纳当前回复为最佳回复

liqupr

发帖: 4粉丝: 0

发消息 + 关注

发表于2021年04月30日 08:47:23 93 2
直达本楼层的链接
楼主
显示全部楼层
[问题求助] 使用docker安装mingspore成功后,使用源码安装mindinsight

我docker容器内使用的版本就是3.7的,为什么还报版本不匹配?

root@da1a4f11a1f8:/mindinsight# python setup.py install
running install
running build
running build_py
creating build/lib/mindinsight
copying mindinsight/__init__.py -> build/lib/mindinsight
copying mindinsight/_version.py -> build/lib/mindinsight
copying mindinsight/__main__.py -> build/lib/mindinsight
running egg_info
building crc32 ...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
AssertionError
Python 3.7 or higher is required. You are running Python 3.6.9
building crc32 failure
root@da1a4f11a1f8:/mindinsight# python
Python 3.7.5 (default, Dec 12 2020, 02:32:46) 
[GCC 7.5.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> exit
Use exit() or Ctrl-D (i.e. EOF) to exit
>>> exit()
root@da1a4f11a1f8:/mindinsight# python --version
Python 3.7.5
root@da1a4f11a1f8:/mindinsight# python setup.py install
running install
running build
running build_py
creating build/lib/mindinsight
copying mindinsight/__init__.py -> build/lib/mindinsight
copying mindinsight/_version.py -> build/lib/mindinsight
copying mindinsight/__main__.py -> build/lib/mindinsight
running egg_info
building crc32 ...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
AssertionError
Python 3.7 or higher is required. You are running Python 3.6.9
building crc32 failure
root@da1a4f11a1f8:/mindinsight# 
举报
分享

分享文章到朋友圈

分享文章到微博

采纳成功

您已采纳当前回复为最佳回复

Skytier

发帖: 1粉丝: 0

级别 : 版主,版块专家

发消息 + 关注

发表于2021年04月30日 08:55:47
直达本楼层的链接
沙发
显示全部楼层

用户您好,您的问题已经收录,请耐心等待一下哦~

点赞 评论 引用 举报

采纳成功

您已采纳当前回复为最佳回复

archimekai

发帖: 3粉丝: 0

发消息 + 关注

发表于2021年04月30日 10:12:30
直达本楼层的链接
板凳
显示全部楼层

您好,MindInsight在编译的时候会优先匹配python3命令,请您检查python3 -V 是否为3.7。如果不是的话,请正确安装python 3.7,确保安装之后 python3 -V 为3.7, python3-config --extension-suffix 为 3.7对应的扩展名。

点赞 评论 引用 举报

游客

富文本
Markdown
您需要登录后才可以回帖 登录 | 立即注册

邀请回答
您可以邀请3位专家

结贴

您对问题的回复是否满意?
满意度
非常满意 满意 一般 不满意
我要反馈
0/200