建议使用以下浏览器,以获得最佳体验。 IE 9.0+以上版本 Chrome 31+ 谷歌浏览器 Firefox 30+ 火狐浏览器
请选择 进入手机版 | 继续访问电脑版
设置昵称

在此一键设置昵称,即可参与社区互动!

确定
我再想想
选择版块
直达楼层
标签
您还可以添加5个标签
  • 没有搜索到和“关键字”相关的标签
  • 云产品
  • 解决方案
  • 技术领域
  • 通用技术
  • 平台功能
取消

采纳成功

您已采纳当前回复为最佳回复

youngyep

发帖: 4粉丝: 0

发消息 + 关注

发表于2021年04月10日 16:27:36 326 11
直达本楼层的链接
楼主
显示全部楼层
[问题求助] 【Atlas 200 DK】【UART1】按例程运行uart1接口,没有数据输出

【功能模块】

Atlas 200 DK 的 UART1接口


【操作步骤&问题现象】

1、https://gitee.com/ascend/samples/tree/master/cplusplus/level1_single_api/5_200dk_peripheral/uart  按照这个案例在atlas上运行,uart1接口的输出信号经示波器检测始终为高电平(16、18引脚)见图一。

2、程序运行结果见图二


【截图信息】

图一、

QQ图片20210410162727.png

图二、

QQ图片20210410162731.png


【日志信息】(可选,上传日志内容或者附件)


举报
分享

分享文章到朋友圈

分享文章到微博
精彩回复

采纳成功

您已采纳当前回复为最佳回复

j_f

发帖: 80粉丝: 31

级别 : 版主,版块专家

发消息 + 关注

更新于2021年04月12日 15:26:56
直达本楼层的链接
显示全部楼层 最佳回复

串口如果没有收到数据,怀疑 1、连线或配置问题;2串口是否烧坏了。3、编译程序版本和制卡版本是否不匹配? 确认下PC toolkit的版本;

可以按下面操作试验下,定位具体原因:

1、使用USB转TTL线

参考这个帖子安装驱动

https://bbs.huaweicloud.com/forum/forum.php?mod=viewthread&tid=82049

单板16,18,20 连接黑、白、绿三色。

2、PC机可以查到串口

uart2.png

3、串口软件如下设置

uart3.png

4、在Atlas200DK 运行 uart样例程序;串口有如下打印:

uart.png

评论
youngyep 2021-4-12 16:32 评论

toolkit包为20.1.rc1

... 查看全部
点赞 评论 引用 举报

采纳成功

您已采纳当前回复为最佳回复

j_f

发帖: 80粉丝: 31

级别 : 版主,版块专家

发消息 + 关注

发表于2021年04月10日 19:34:28
直达本楼层的链接
沙发
显示全部楼层

你好,请问14,16,16三个引脚你是怎么接的?对端的波特率设置的多少?

三个引脚需要分别接地、RXD、TXD?

按样例中参数,波特率设置为115200;

对端收到类似下面的字符。

char send_mid[] = "#0P1650T500\r";
char send_left[] = "#0P1180T500\r";
char send_right[] = "#0P2000T500\r";
点赞 评论 引用 举报

采纳成功

您已采纳当前回复为最佳回复

youngyep

发帖: 4粉丝: 0

发消息 + 关注

发表于2021年04月10日 23:28:54
直达本楼层的链接
板凳
显示全部楼层

回复:j_f 发表于 2021-4-10 19:34 你好,请问14,16,16三个引脚你是怎么接的?对端的波特率设置的多少?三个引脚需要分别接地、RXD、TXD?按样例中参数,波特率设置为115200;对端收到类

三个引脚是接的正确的,波特率也是设的115200,但是完全收不到任何数据。

直接用示波器测Atlas 200 DK上的16,18引脚,发现都是3.3V,这个样例运行后并无改变,仍然均为3.3V。


点赞 评论 引用 举报

采纳成功

您已采纳当前回复为最佳回复

j_f

发帖: 80粉丝: 31

级别 : 版主,版块专家

发消息 + 关注

更新于2021年04月11日 18:31:22
直达本楼层的链接
地板
显示全部楼层

你好,从打印看,程序运行没有异常。需要进一步信息才能鞥定。

1、请确认是否按照样例readme做了如下配置?

1.png

2、串口连接线、对端串口配置能否都发张截图?

3、请反馈使用的CANN版本,以及开发板系统软件版本。

https://support.huaweicloud.com/environment-deployment-Atlas200DK202/atlased_04_0033.html


点赞 评论 引用 举报

采纳成功

您已采纳当前回复为最佳回复

youngyep

发帖: 4粉丝: 0

发消息 + 关注

发表于2021年04月12日 10:29:05
直达本楼层的链接
5#
显示全部楼层

回复:j_f 发表于 2021-4-11 16:38 你好,从打印看,程序运行没有异常。需要进一步信息才能鞥定。1、请确认是否按照样例readme做了如下配置? 2、串口连接线、对端串口配置能否都发张截图?3、请反

1.我确认按照样例进行了配置

16_E@PP4M81MGW@PG{JG}WT.png

2.我现在的情况是atals 200 dk开发板上的uart1引脚似乎根本没有启用(一直为高电平),这与连接线无关。

3.我的环境是直接参照《Atlas200DK分设--20.1版本极简安装手册.docx》搭建的(驱动与固件版本为1.0.8.alpha;cann版本为3.1.0),按照您给的链接执行命令后结果如下:

image-20210412101856080.png

Atlas200DK分设--20.1版本极简安装手册.docx 2.35 MB,下载次数:4

点赞 评论 引用 举报

采纳成功

您已采纳当前回复为最佳回复

youngyep

发帖: 4粉丝: 0

发消息 + 关注

发表于2021年04月13日 09:24:05
直达本楼层的链接
7#
显示全部楼层

回复:j_f 发表于 2021-4-12 10:53 串口如果没有收到数据,怀疑 1、连线或配置问题;2串口是否烧坏了。3、编译程序版本和制卡版本是否不匹配? 确认下PC toolkit的版本;可以按下面操作试验下

刚刚经过测试,发现gpio接口可以正常使用,但是uart接口仍然没有数据输出。在另一块atlas 200 dk上测试和我的情况一样。

点赞 评论 引用 举报

采纳成功

您已采纳当前回复为最佳回复

j_f

发帖: 80粉丝: 31

级别 : 版主,版块专家

发消息 + 关注

更新于2021年04月13日 11:01:25
直达本楼层的链接
8#
显示全部楼层

你好,

1、你方便时定个腾讯会议,私信我,远程定位下。

2、能否单板正反面拍照,确认下是A版,还是B版 ?IT21VDMA/IT21VDMB

点赞 评论 引用 举报

采纳成功

您已采纳当前回复为最佳回复

youngyep

发帖: 4粉丝: 0

发消息 + 关注

发表于2021年04月13日 12:10:12
直达本楼层的链接
9#
显示全部楼层

回复:j_f 发表于 2021-4-13 10:54 你好,1、你方便时定个腾讯会议,私信我,远程定位下。2、能否单板正反面拍照,确认下是A版,还是B版 ?IT21VDMA/IT21VDMB

1.谢谢,我们打算更换方案,不用uart了,采用usb或者网线与主机(搭载ubuntu系统的车载pc)通信

2.

ORK0GHN)UCU6(6NQ%MXF3DO.png

SH95R@JDU49ILMM`VSIH430.png



点赞 评论 引用 举报

采纳成功

您已采纳当前回复为最佳回复

youngyep

发帖: 4粉丝: 0

发消息 + 关注

发表于2021年04月13日 17:33:35
直达本楼层的链接
10#
显示全部楼层

还想问一下,atlas上的usb口是不是不能作为master?有什么用网线和开发环境传输数据的案例吗?

点赞 评论 引用 举报

游客

富文本
Markdown
您需要登录后才可以回帖 登录 | 立即注册

邀请回答

结贴

您对问题的回复是否满意?
满意度
非常满意 满意 一般 不满意
我要反馈
0/200