建议使用以下浏览器,以获得最佳体验。 IE 9.0+以上版本 Chrome 31+ 谷歌浏览器 Firefox 30+ 火狐浏览器
请选择 进入手机版 | 继续访问电脑版
设置昵称

在此一键设置昵称,即可参与社区互动!

确定
我再想想
选择版块
直达楼层
标签
您还可以添加5个标签
  • 没有搜索到和“关键字”相关的标签
  • 云产品
  • 解决方案
  • 技术领域
  • 通用技术
  • 平台功能
取消

采纳成功

您已采纳当前回复为最佳回复

五湖四海@银河护卫队

发帖: 176粉丝: 73

级别 : 版主,版块专家

发消息 + 关注

更新于2021年04月10日 13:54:51 387 1
直达本楼层的链接
楼主
显示全部楼层
[技术干货] SUSE 12.5安装qemu报Cannot find suitable emulator for aarch64解决方法

【问题描述】

SUSE 12.5 for arm系统通过zypper install qemu*安装qemu后,执行systemctl status libvirtd.service查看qemu状态时报Cannot find suitable emulator for aarch64错误,详细报错如下:

libvirtd[15094]: internal error: Failed to start QEMU binary /usr/bin/qemu-system-ppc64 for probing: qemu-system-ppc64: cannot initialize crypto: Unable to initialize gcrypt

libvirtd[15094]: Failed to probe capabilities for /usr/bin/qemu-system-ppc64: internal error: Failed to start QEMU binary /usr/bin/qemu-system-ppc64 for probing: q...tialize gcrypt

libvirtd[15094]: internal error: Failed to start QEMU binary /usr/bin/qemu-system-ppc64 for probing: qemu-system-ppc64: cannot initialize crypto: Unable to initialize gcrypt

libvirtd[15094]: Failed to probe capabilities for /usr/bin/qemu-system-ppc64: internal error: Failed to start QEMU binary /usr/bin/qemu-system-ppc64 for probing: q...tialize gcrypt

libvirtd[15094]: internal error: Failed to start QEMU binary /usr/bin/qemu-system-s390x for probing: qemu-system-s390x: cannot initialize crypto: Unable to initialize gcrypt

libvirtd[15094]: Failed to probe capabilities for /usr/bin/qemu-system-s390x: internal error: Failed to start QEMU binary /usr/bin/qemu-system-s390x for probing: q...tialize gcrypt

libvirtd[15094]: internal error: Failed to start QEMU binary /usr/bin/qemu-system-x86_64 for probing: qemu-system-x86_64: cannot initialize crypto: Unable to initialize gcrypt

libvirtd[15094]: Failed to probe capabilities for /usr/bin/qemu-system-x86_64: internal error: Failed to start QEMU binary /usr/bin/qemu-system-x86_64 for probing:...tialize gcrypt

libvirtd[15094]: invalid argument: could not find capabilities for arch=aarch64 domaintype=qemu

libvirtd[15094]: internal error: Cannot find suitable emulator for aarch64

image.png


执行/usr/bin/qemu-system-aarch64报如下错误

qemu-system-aarch64: cannot initialize crypto: Unable to initialize gcrypt

image.png


【解决方法】

执行zypper install libgcrypt*安装相关依赖

image.png

执行systemctl restart libvirtd.service重启libvirtd.service服务即可

然后查看libvirtd.service状态systemctl status libvirtd.service

image.png





举报
分享

分享文章到朋友圈

分享文章到微博

采纳成功

您已采纳当前回复为最佳回复

Jack20

发帖: 233粉丝: 180

发消息 + 关注

发表于2021年04月12日 13:06:57
直达本楼层的链接
沙发
显示全部楼层

谢谢分享

点赞 评论 引用 举报

游客

富文本
Markdown
您需要登录后才可以回帖 登录 | 立即注册

结贴

您对问题的回复是否满意?
满意度
非常满意 满意 一般 不满意
我要反馈
0/200