建议使用以下浏览器,以获得最佳体验。 IE 9.0+以上版本 Chrome 31+ 谷歌浏览器 Firefox 30+ 火狐浏览器
请选择 进入手机版 | 继续访问电脑版
设置昵称

在此一键设置昵称,即可参与社区互动!

确定
我再想想
选择版块
直达楼层
标签
您还可以添加5个标签
  • 没有搜索到和“关键字”相关的标签
  • 云产品
  • 解决方案
  • 技术领域
  • 通用技术
  • 平台功能
取消

采纳成功

您已采纳当前回复为最佳回复

五湖四海@银河护卫队

发帖: 175粉丝: 72

级别 : 版主,版块专家

发消息 + 关注

发表于2021年02月25日 20:29:20 915 2
直达本楼层的链接
楼主
显示全部楼层
[技术干货] 编译netty报karaf-maven-plugin:jar:3.0.0-SNAPSHOT is missing错误解决方法

【问题描述】

编译netty 4.0.0.Beta14.0.0.Beta24.0.0.Beta3等版本执行mvn install时报karaf-maven-plugin:jar:3.0.0-SNAPSHOT is missing等错误,详细报错如下:

The POM for org.apache.karaf.tooling:karaf-maven-plugin:jar:3.0.0-SNAPSHOT is missing, no dependecy information available

[ERROR] [ERROR] Some problems were encountered while processing the POMs:

image.png


【解决方法】

修改testsuite-osgi/testsuite-osgi-deps/pom.xml文件:

image.png

将karaf-maven-plugin的依赖版本号从3.0.0-SNAPSHOT修改为3.0.1:

image.png


【注】:在netty的4.0.0.Beta14.0.0.Beta24.0.0.Beta3等3个版本需要修改testsuite-osgi/testsuite-osgi-deps/pom.xml文件中karaf-maven-plugin的依赖版本号


举报
分享

分享文章到朋友圈

分享文章到微博

采纳成功

您已采纳当前回复为最佳回复

Jack20

发帖: 193粉丝: 173

发消息 + 关注

发表于2021年02月25日 21:47:47
直达本楼层的链接
沙发
显示全部楼层

谢谢分享

点赞 评论 引用 举报

采纳成功

您已采纳当前回复为最佳回复

重新来过

发帖: 212粉丝: 12

发消息 + 关注

发表于2021年02月25日 22:33:37
直达本楼层的链接
板凳
显示全部楼层

学习了,是因为版本号不对吗

评论

是的,源码依赖中的jar版本号不存在,还有其他情况是源码中依赖版本号的jar有问题导致编译失败需要替换其他版本的;

... 查看全部
点赞 评论 引用 举报

游客

富文本
Markdown
您需要登录后才可以回帖 登录 | 立即注册

结贴

您对问题的回复是否满意?
满意度
非常满意 满意 一般 不满意
我要反馈
0/200