Linux提示Unable to locate package该如何处理?

SHQ5785 发表于 2022/06/25 10:53:25 2022/06/25
【摘要】 当你在修改Linux软件源的时候,提示Unable to locate package错误,这是由什么原因导致的呢?又该如何解决,下面就给大家介绍下Linux下遇到Unable to locate package错误的情况该如何解决,一起来学习下吧。Linux提示Unable to locate package该如何处理?刚开始接触ubuntu的朋友可能会按照一些入门文章的步骤更改软件源,可...

当你在修改Linux软件源的时候,提示Unable to locate package错误,这是由什么原因导致的呢?又该如何解决,下面就给大家介绍下Linux下遇到Unable to locate package错误的情况该如何解决,一起来学习下吧。

Linux提示Unable to locate package该如何处理?

刚开始接触ubuntu的朋友可能会按照一些入门文章的步骤更改软件源,可是此时安装软件的话会出现unable to locate package的错误

例如:

代码如下:

username@ubuntu:~$ sudo apt-get install vi

[sudo] password for username:

Reading package lists… Done

Building dependency tree

Reading state information… Done

E: Unable to locate package vi

username@ubuntu:~$

其实问题出在执行sudo apt-get install之前更换了软件源,但是却忘了update下了,于是执行下面的命令:

代码如下:

sudo apt-get update

等上面命令执行完后,再执行sudo apt-get install就可以了!其实错误信息已经很明确了,Unable to locate packet就是无法找到包嘛,那还不赶紧sudo apt-get update下!这样一来问题就解决了…

上面就是Linux下出现Unable to locate package错误的解决方法介绍了,主要是由于忘记update下而导致的,只需按照本文的方法就能轻松解决该问题,赶紧试试看吧。

【版权声明】本文为华为云社区用户原创内容,未经允许不得转载,如需转载请发送邮件至:cloudbbs@huaweicloud.com;如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容。
  • 点赞
  • 收藏
  • 关注作者

评论(0

0/1000
抱歉,系统识别当前为高风险访问,暂不支持该操作

全部回复

上滑加载中

设置昵称

在此一键设置昵称,即可参与社区互动!

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。

*长度不超过10个汉字或20个英文字符,设置后3个月内不可修改。